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History 

The Seismology Research Centre 
The Seismology Research Centre (SRC) was established in 1976. In 1977 the SRC began 

developing “Kelunji” digital seismic recorders, starting with the Alpha and Beta tape-based 

recorders (later renamed Yerilla). The first Kelunji-branded recorder was later referred to as 

the Classic, which was followed by the D-series, Echo, EchoPro, and the current Kelunji Gecko. 

 

Above: the original 2015 Gecko Compact seismic recorder, next to an iPhone 6 for scale 

Data Formats 

The Kelunji Gecko was our first recorder to natively store data in MiniSEED format. MiniSEED 

data files do not include information about the recorder or sensor gains and sensitivity factors, 

but the Gecko stores this information in a simple text file in each data folder. Waves will 

automatically read the file if it is present, displaying your data in real ground motion units. 

You can then save this extra data into the file by saving it in PC-SUDS format. 

When the Kelunji D-series was introduced in the mid 1990s the SRC decided to adopt a global 

standard data format for our seismic recorders. The SUDS (Seismic Unified Data System) 

was originally created at the U.S. Geological Survey and adopted for use in the IASPEI 

Seismological Software Library, where it became known as PC-SUDS. It is a very flexible 

format which contains many fields for information relating to the raw data, which has enabled 

our Waves software to provide very useful information to Kelunji users. 

For more information on SUDS, visit http://banfill.net/?page_id=16  

Waves can also read other data formats including: KA1, KA2, Yerilla, SEG-Y, SEG2, GSE 2.0 

(AutoDRM), CSS waveform binary (.w), CSS arrival text (.wfdisc) and CSV text. Waves will 

automatically decompress any files that use .zip, .gz or .xz compression. 
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Installing Waves 

Java Not Required 

Waves 4.0 includes everything it needs to run as a stand-alone Windows, macOS or Ubuntu 

application, so unlike previous versions of Waves you no longer need to have Oracle’s Java 

Runtime Environment (JRE) installed. 

Waves Workspace 

When Waves starts up, you will be presented with the window below, with a toolbar containing 

buttons for some commonly used function. The main workspace is where the waveforms will 

appear, and below this is a pull-up window that reveals the frequency spectrum display. 

 

Drop a MiniSEED, SUDS or other compatible file from your computer’s file browser onto the 

workspace to view the waveform, then start analysing your seismograms. 

 

WAVES MAIN WORKSPACE 

DRAWER SLIDER 

Drag up for frequency spectrum display 
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Toolbar & Channel Buttons 
 Shortcut Key Description 

 
 If you have 3 or more arrival picks, enter Location feature 

 
Page Up Zoom in to the timeline (or zoom to selection) 

 
Page Down Zoom out of the timeline (centred on click or selection) 

 
Home Display full timeline and amplitude 

 p, s Select the arrival types to mark on the time line 

 
w Set the arrival marker selected in the drop down list 

 
 Switch between Individual and Fixed Amplitude Scaling 

 
 Switch between Displayed and no Zero Offset correction 

 
 Trim the working file to only the displayed data 

 
⌘-g Display the 3D vector sum (peak particle motion) 

 
 Display the 2D vector sum (peak horizontal motion) 

  Enter a time correction for the selected station (seconds) 

 b or n Open next file if name includes this text, use (B)ack or (N)ext 

 
Sort Re-apply the station order sorting 

 g Filter all channels using the Preset frequency band 

 h Filter all channels to the Custom frequency band specified in 
fields to the right of the button 

 j Clear frequency filter from all channels 

  Per-channel filters – functions as above 

 ⌘-i Channel Information 

  Flip channel polarity (black arrow up=normal, down=reverse) 

  Show/hide channel rotation controls (coloured if changed) 

  Show/hide channel elevation controls (coloured if changed) 

 k (on), l (off) Show/hide channel spectrogram plot. Shortcut keys affect all 
channels – turning all spectrograms on will take some time 
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Controls 
Note: where you see the ⌘ symbol in this manual, it represents the Control key on Windows and 

Linux, or the Command key on macOS, unless otherwise specified. 

Zooming & Scrolling 
All zoom commands are applied to all channels at the same time. 

Scroll-zoom 

While holding down the right mouse button or the CONTROL key, roll your scroll wheel to 

zoom in and out to your cursor’s location on the time line. The zoom speed can be adjusted 

in the “Controls” setting. Note that some touch-based pointing devices (e.g. macOS 

trackpads) may not behave as expected when scroll-zooming. Double right-clicking your 

mouse will reset the zoom level to the full timeline, as will clicking the  button. 

Click-zoom 

Clicking and dragging your cursor over the waveform will show a red vertical marker bar. 

Move to the area you want to zoom into and release the cursor-click to leave a light grey 

marker line. Click the  button or PAGE-UP shortcut key to zoom in to the marker or use the 

 button or PAGE-DOWN shortcut key to zoom out, centred on the marker. 

This zoom speed is also adjusted by the zoom “Controls” setting. 

Swipe-zoom 

Instead of left-clicking and dragging a marker line, you can right-click and drag to highlight 

an area of interest. After releasing the click, place your cursor over the highlighted section 

and you will notice that your cursor changes into a magnifying glass. Click to zoom the 

highlighted area to full window width. 

Timeline scrolling 

Use the left and right arrows on your keyboard to scroll the time line, or holding down the 

ALT key and using the scroll wheel. 

Amplitude scaling 

Use the up and down arrows on your keyboard to double or halve the signal amplitude of all 

channels. Use the  button or HOME keyboard shortcut to revert the amplitude.  
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Picking Arrivals 

The main function of Waves is to pick earthquake wave arrival times on the recordings to 

allow the determination of the location and magnitude of the earthquake. We will cover the 

basics of picking P and S wave arrivals and calculating earthquake location and magnitude 

later in this user manual. 

To mark a phase arrival time, click and drag the cursor to the point of interest on a channel 

and release to leave a grey marker line. Select a type of arrival from the drop-down list. This 

list of arrivals is based on a customisable text list in a (new to Waves 4.0) settings tab. 

Once the marker line is in place, click the  toolbar 

button (or use the W shortcut key) to mark the 

selected phase time on the station (or channel, in 

the case of X markers). 

You can use keyboard shortcuts to set P, S and MAX 

arrivals, as well as X to mark a channel stacking 

marker. The most commonly used seismology 

arrival phase codes are listed in the Arrival Settings 

list, but you add any text you like into the list to use 

as a time mark identifier. 

Amplitude Grouping 

To maximise the detail of the displayed data, Waves will scale the amplitude of each channel 

to fill the vertical space allowed for each channel, which means each channel will have an 

Individual peak amplitude scale on the Y-axis. You can choose to group the amplitudes by 

Location, which will scale all channels with the same station and location code to the largest 

channel’s amplitude. You can group All channels to the single largest amplitude in the file, 

regardless of station code. Finally, you can scale Acceleration, Velocity, or Displacement 

waveforms to a Fixed peak value as defined in the “Display” Settings. 

Clicking the  button will toggle between Fixed and Individual modes, but other modes are 

available in the Display menu. Channels that have been converted from their natural units 

(usually velocity or acceleration) to other units will always scale individually. 
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Zero Correction 

When a sensor is plugged into a recorder it will almost always have some level of signal offset, 

which can be due to the sensor not being perfectly level or the sensor components requiring 

some sort of electronic adjustment. The raw data is never modified by Waves, only the way 

it is displayed. Each channel is corrected individually. The offset correction can be based on 

the zero-offset of the visible data (Displayed) or based on the average zero level of the 

entire record (All), or zero-offset connection can be turned off (None), or the zero level can 

be displayed as the mid-way point between the positive and negative displayed peak signal 

level (Peak to Peak) by selecting the mode in the Display menu. The  toolbar button 

toggles between Displayed and None. 

 

Trim 

The  tool will delete all hidden channels and data outside the currently visible time line, 

leaving you with a new file that needs to be saved separately. When using the Trim tool, the 

original data file is closed, whereas when using the “Copy Visible to New File” in the Edit menu, 

the original data file remains open in a window behind the new trimmed data file. 

  

NONE DISPLAYED 

ALL PEAK to PEAK 
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Vector Sum 

We are often using sensors that record in three dimensions, usually set up in the east-west, 

north-south, and up-down axes, but sometimes they are aligned relative to a structure or 

event, such as along a dam or pointing towards a blast. The peak motion from the event will 

not necessarily be in one of these axes, so to calculate the peak value we can apply a 3D 

vector sum formula to the data. Kelunji data is recorded in triaxial groups, or you can 

manually group channels using the channel location code. 

By using the  button while channel is selected (or choosing “3D Peak Motion Plot” from the 

Display menu, or using the ⌘-G shortcut) a new Waves window is displayed showing the peak 

particle motion plots. 

 

If the original ground motion units are known, the new window will show the vector sum in 

the original units as well as the other two related units. In the example above, the original 

green velocity traces have been summed, and the vector sums of the calculated displacement 

and acceleration traces are also shown. Without some filtering, integrated ground motion 

units (going from acceleration to velocity, or velocity to displacement) can contain low 

frequency artefacts, so Waves automatically applies a 0.1Hz high pass filter to 3D plots, but 

in “Filter & Convert” Settings you can set the filter band manually (leave blank for no filter). 

If you only wish to see the peak motion of the two horizontal channels in the triaxial group, 

use the  button to display a 2D vector sum peak motion plot in the available units. 

Using the “Sync” feature 
Older instruments did not use GPS and relied on internal clocks for timing. Clock errors can 

be corrected by time-shifting data using the “sync” feature. A Sync value from 0 to 30 seconds 

shifts the data back in time, and a sync of 30 to 60 seconds will shift data forward. Enter a 

value into this field and hit Enter to adjust the time line for the selected station code. 
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File Filter 

The File Filter field in the toolbar is linked to the file browsing tool in the File menu. If any 

characters have been typed into this field, when you use the Next File (n) or Previous File 

(b) commands, only valid files that contain those characters in the filename will be opened. 

Leave the field blank to remove the file filter and open the next valid file in the folder. 

Frequency Filters 
A user will typically be interested in a 

particular frequency band, so Waves allows 

the definition of a blue “favourite” Preset band 

pass filter. Waves also allows the user to set a 

variable frequency band pass filter by typing 

values into the fields to the right of the orange 

button in the toolbar. The red filter button 

clears the filters. The Toolbar filter buttons will 

apply to all channels (or all visible channels, 

according to your “Filter & Convert” Settings 

which is discussed later in this user manual). 

Once a filter has been applied to a channel, 

the pass band is written in text to below the 

channel filter buttons so that you are aware 

that the data displayed has been filtered. 

Viewing spectrograms is covered in more 

detail later in this user manual, but note that 

the frequency range of the spectrogram will 

also change according to the channel filter 

settings to maximise the resolution of the 

visible frequencies in the spectrogram. 

You can enable and disable filters on individual 

channels by clicking on the small filter buttons 

in the top right corner of each channel. 
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To illustrate the effect of the filter when converting data between ground motion units, in the 

example below the upper trace is a high gain accelerometer and the lower trace is a 1Hz 

velocity sensor. Converting the acceleration trace to velocity and filtering it from 1Hz to 50Hz 

yields a similar trace to the seismometer. 

    

Removing the filter altogether shows the artefacts of integration (below, left), but setting the 

low end frequency to 0.05Hz (20 seconds, below right) reveals the long period signal. Unit 

conversion and frequency filtering 

are very important tools in 

revealing phase information. 

Sometimes arrivals are clearer in 

Displacement. Play with your data 

and see what you can find! 

Waveform Display Elements 
Once you have opened a waveform file, the data will be plotted in the main Waves window 

showing the full time line of available data. The basic elements of the display will be 

described briefly below and expanded upon in later sections of the manual. Channel-specific 

controls only appear when your cursor is hovering over the channel data. This helps to 

unclutter the display when many channels are displayed. 
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Decoding the Y-axis Labels 

The station code is displayed 

to the left of the Y-axis, with 

the channel name and 

location ID below it. 

The colour of the text 

indicates the units of the 

original data (green is 

velocity, red is acceleration). 

The value above the station 

code is the peak ground 

motion amplitude of that 

channel for the displayed time span of data. At the top of the Y-axis you will see a label in 

black text indicating the maximum displayed units and recorder counts. In the example 

above, the peak amplitude of the displayed data is 1.031mm/s but the amplitude scale clips 

because the user has enabled Fixed Amplitude display mode, set to 0.5mm/s. 

Display of Ground Motion Units 
If a channel is recognised as having units in velocity, the trace and station code will be drawn 

in green. If a channel is defined as acceleration, the trace and station code will be drawn in 

red, and displacement in black. 

You can convert between these units by clicking on the buttons in the top left corner of each 

waveform trace. The waveform colour will change, but the station code will remain in the 

original recorded unit colour. Other recognised units are pressure, rotation, and voltage. 

Any unrecognised units are displayed in dark grey. The    buttons will disappear 

for pressure, rotation and other units as they cannot be transformed. 

Minimise and Maximise Channels 

To the immediate left of these ground motion conversion buttons are the minimise and 

maximise buttons. Use the  button to maximise the view of a channel to full screen and the 

 button to go back. When all channels are shown, use the  button to hide that channel 

from view. To restore all hidden channels, go to the Channels menu and select to show All 

or show Vertical channels, or the channels of a specific site. 
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Channel Rotation 

If you have opened a triaxial seismogram, the North channel should show a  compass 

symbol, and the vertical channel should show an  angle symbol. Click on the symbol to 

open up the rotation and elevation adjustment controls. 

 

The assumption is that your sensor was oriented aligned to North (0°). By clicking on the 

purple degree adjustment buttons on the North channel, the seismogram will be rotated 

around the vertical axis and the North and East channels will change. The rotation icon will 

change from light to dark to show an adjustment has been made, even after the tool is closed. 

 sensor at 0° rotation  sensor rotated to +45° 

Similarly, by clicking on the teal elevation adjustment buttons on the Vertical channel, the 

seismogram will be rotated around the North-South axis, so the Up and East channels will 

change. The elevation icon will change from light to dark to show it has been modified. 

 sensor at 0° elevation  sensor elevated to +6° 

N N 
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Channel Polarity 

A sensor is normally set so that a positive signal equates to positive motion in the East, North 

or Up direction, but this can vary due to sensor orientation or sensor wiring. If you find that 

a channel has the opposite polarity, you can flip it by clicking on the  button. If the black 

arrow is facing up, the original data is being displayed; if the black arrow is facing down it 

indicates that the reverse polarity data is being displayed. 

Channel Information 
Once you click on a channel its Y-axis bar will be slightly thicker than other channels to show 

that information relates to this channel (e.g. the frequency spectrum display or channel 

information display). When you click on the  button, type ⌘-I, or select Channels ▶ Info 

a window will pop up displaying extra information about this channel and its station. 

The left side of the General tab has editable 

elements related to the Station and Channel 

codes, as well as scaling factors to allow the 

raw data counts to be scaled to real-world 

units. If the GPS position of the station is 

available, a small marker will appear next to 

the station name which when clicked will 

show the station location in your web 

browser using Google Maps. 

You can switch to a different channel that 

shares the station code and network ID using 

the drop-down Channel field menu, or click 

into the field to edit the channel name. 

On the right side of the window an Instrument Information pane shows some recorder and 

sensor parameters, such as battery voltage and temperature, serial numbers, and any other 

fields that can be decoded from the data file.  

If you need to modify the system response (e.g. if you have opened a data-only MiniSeed file 

without an accompanying station.xml file) you can modify the displayed fields and click OK to 

apply these channel settings. If you have a single “Sensitivity” value for your channel, enter 

it into the “Counts Per Volt” field and put a value of 1 for “Volts Per Unit” and “Flat Gain”. 

Note that Acceleration units are specified in V/m/s2, but accelerometers are usually specified 

in Volts-per-g, so adjust the value accordingly. For example 10V/g = 1.0197162 V/m/s  
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Poles & Zeroes 

The second tab on the Info window is 

labelled Poles and Zeroes and allows you 

to enter the Poles and Zeroes for the sensor 

channel group. 

Adding this information changes the Power 

Spectral Density (PSD) plot, as shown in 

the images below. The left image is the raw 

data with ground motion scaling only, and 

the right image has the poles and zeroes 

corrections applied. The raw time series 

waveform data is unchanged. 

 

Meta Data and Station.xml 

The third tab will have different labels depending on the format of the data file and whether 

or not it contains meta data. Kelunji D-series, Echo and EchoPro SUDS files Comments field 

will be displayed in the tab, as will Kelunji Gecko settings.ss file contents. 

If you have opened a MiniSEED file from a folder that also contains a related station.xml 

file, the .xml file contents will be displayed in the tab. If there is no .xml file, Waves will 

look up the IRIS DMC for a channel that matches the station/network/location ID and 

automatically populate the meta data fields. Waves will also store the station.xml file in 

your user/eqsuitefiles/response folder for future use. 

Channel Filters 
The next three buttons are the individual channel filter control buttons. Please see the earlier 

section on Filtering to learn about the function of the blue, orange and red filter buttons. 
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Spectrogram 

The  button will show and hide the spectrogram for a channel. This will split the waveform 

area into two rows, squeezing the time series ground motion trace into the top half and the 

time series frequency spectrum into the bottom half. This display mode works best when a 

channel is maximised. Using shortcut key K will open the spectrogram window for all channels 

(many channels can take some time), and L will close all of the spectrogram windows. 

By default the scaling of the spectrogram is a log-log plot, best for looking at low frequency 

signals. You can switch the spectrogram scaling to linear plots by clicking on the  button 

in the top right of the spectrogram, or revert to log plot by clicking the  button. The 

frequency or period of the data under your cursor is displayed to the left of the Y-axis of the 

spectrogram: shown in Hertz when the value is above 1Hz; and shown in Period (seconds) 

for values below 1Hz. 

The spectrogram shows the intensity of frequency over a sampling period. If the sampling 

window is too narrow you will see a vertically streaky spectrogram (below, left) and if the 

sampling window is too wide the spectrogram will appear smeared over time (below, right). 

You can widen or shorten the sampling window by using the and  buttons until you can 

see the frequency content at a usable resolution. 

 

The spectrogram colours scale to the highest intensity of the displayed data, which can 

dominate the plot during an earthquake, which can obscure the pre-event and post-event 

frequencies. You may 

want to see if there is a 

change in the natural 

frequency of your 

building, which means 

looking for a shift in this 

resonance before and 

after an earthquake. 

Use the  and  

buttons to increase or 

decrease the frequency 

intensity level.  
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Frequency and Power Spectrum Display 

Press the F shortcut key to toggle the frequency display window open or closed, or drag up 

the horizontal divider bar at the bottom of the Waves window. You can adjust the size of this 

window by dragging the divider bar up or down. Initially it will display a linear-scaled Fast 

Fourier Transform (FFT) frequency spectrum of the currently selected data. 

Right-click any channel to display the frequency spectrum for the full time series, or right-

click-and-drag to see the frequency spectrum of a selected time period. Note that the selected 

channel has a thicker Y-axis bar and is named in the top left corner of the FFT window. You 

can click and drag over a section of the frequency plot, then place your pointer over the 

highlighted section and click to zoom in for a more detailed view. 

In the top right corner of the FFT window you’ll 

see a toolbar that allows you to edit the view and filter the data. The magnifying glass icon 

will reset the zoom to the full frequency range. 

Filtering in the Frequency Domain 

The  button in the frequency window tool bar displays the FFT on a linear frequency scale. 

Clicking on the  button when displaying linear FFT will change the graph to a log-log plot.  

You can use this FFT window to filter your data. Right-click and drag to select a frequency 

range, then click the  to keep only that frequency range. The time series data will then be 

redrawn based on the filtered frequency data.  

Conversely, click the  after 

highlighting a frequency range to 

reject the selected range.  

In the example shown, inadequate 

shielding from AC power results in 

50Hz noise dominating the signal. 

By click-and-dragging over the 

anomalous frequency band and 

clicking the  button in the top 

right of the FFT window, the 

highlighted region is dropped out 

and the time series waveform is 

then redrawn.  
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The notch filter can be applied repeatedly over the frequency spectrum, as shown below.  

 

To clear all filters from the channel, click the  button in the FFT window or on the channel. 

Power Spectral Density Plot 

While you are viewing the FFT log 

plot, click the  button again and 

the graph will toggle to a Power 

Spectral Density (PSD) plot. The 

horizontal range of this log-scale 

plot shows data from a long 

period to the decade above the 

Nyqvist frequency. If a band pass 

filter has been applied, the 

horizontal scale will span the 

decades either side of the pass 

band. 

The  button shows the PSD 

relative to the Peterson New Low 

Noise Model (NLNM) and New 

High Noise Model (NHNM) curves, 

from 1000 seconds to 10Hz. You 

can still zoom and filter the 

frequency range in the PSD and 

Peterson Model plot views. 

This gives you an idea of the 

noise level of your station.  
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File Menu 

Opening and Closing Files 
You can drag a file from your computer’s file browser onto the Waves window to view it. 

You can also use the File ▶ Open menu item (⌘-O) to browse your computer for your file. 

To close the file and go back to an empty Waves window use the operating system’s window 

close button, File ▶ Close menu item, or ⌘-W. 

When you have a file open, you can open another file by dragging it onto the Waves window 

or using the Open command again, but this will open the file in a new Waves window. If you 

would like to merge the additional files into the same Waves window, read on. 

Merging Files 

Waves can merge up to 24 hours of data from many stations into a single file. Kelunji seismic 

recorders store continuous data in one-minute-long data files, so it is possible that an 

earthquake recording will straddle two or more files. To make analysis easier you can merge 

these files together on screen and then save the merged file to your computer. 

The quickest way to merge several files into a single viewer window is to multi-select files in 

your operating system and drag them into the Waves window while holding down the Control 

key on Windows or macOS, or the Shift key on Linux. 

 

Alternatively, use the File ▶ Open command, select the files you wish to merge using your 

multi-select file system shortcuts (usually Shift, ⌘ Command or Option-clicking) and tick the 

“Merge into current file” checkbox before clicking the button to proceed. 
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Merging Folders 

If you File ▶ Open on a folder or drag a folder containing files onto Waves, all of the contents 

of the folder (and sub-folders) will be merged into a single (24-hour maximum) timeline. This 

is a quick way to view an entire hour or day folder from a Gecko’s SD card. 

When merging, as long as all of the files are within a 24-hour time period, they will be merged 

onto a common time line, grouped by site code in alphabetical order. Your computer’s memory 

will limit to how much data is practical to open in a single window, which will depend on 

sample rate, number of stations, and number of channels. 
Exporting Data 
To quickly save a file to your last “Save As…” folder for later review, use the File ▶ Auto Save 

(Y) command. This is useful when you are reviewing a folder full of seismograms using the N 

and B shortcuts and you come across a file that you would like to review in detail a bit later. 

After quick-saving, Waves will automatically open the next file in the folder. 

Once you have merged, clipped, or modified your seismogram file you can save it using the 

File ▶ Save command or ⌘-S. This will overwrite the file whose name is displayed in the title 

bar or the Waves window. 

“Save As” file and name formatting 

If you do not wish to overwrite the file, you can use File ▶ Save As or ⌘-T to save your data 

to a new file. In the Save dialog box that pops up there are control options for naming the 

file. The “SRC” filename format follows the form: YYYY-MM-DD hhmm ss STATION 

If you are saving a merged file the STATION code in the file name will be one of the channels 

from the recording, depending on the order in which they were merged by the system. 

If you decide to use the “GA” filename format, the file will be named in the form 

SITEYYDDD_hhmmss where YY is the last two digits of the year (e.g. 13 for 2013) and DDD 

is the day number of the year (i.e. 001 to 366). 

By default Waves will save files in gzip compressed PC-SUDS format (file extension: .dmx.gz) 

which embeds station data in the file format. You can also save as a MiniSEED zip file, which 

creates a zip compressed folder containing the MiniSEED waveform and a companion text file 

with the station response. Waves can them open compressed files and automatically apply 

the station corrections. Other text based formats are available, which can be imported into 

spreadsheets, text processors, or mathematical processing and plotting applications. 

See “Basic Analysis” later in this manual to understand how saving a .kml format file from a 

multi-station waveform with P & S picks can be used to estimate the earthquake epicentre. 
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CSV file format 

When you save your seismogram as a CSV file, it is in ASCII format using commas for 

separating the values in the file. CSV files are easily read using Excel. 

It contains a header that describes the Arrivals contained in the file, a section that describes 

the time series data in the file, followed by the data points. 

Any arrival information contained in the seismogram will be listed in the first section. Each 

arrival will have its own column detailing the site name, arrival type and time. 

The next section describes the time series data, one channel per column. This includes the 

site name, channel name, the date and time of the first data point (or “sample”), and how 

many samples there are per second. As you may have merged data of differing sample rates, 

there may be a variable number of rows per column for a given time period. 

The final row before the data points indicates the units of the data, which could be metres 

(m), metres per second (m/s), metres per second squared (m/s/s), etc. The data is then 

displayed in these units, one sample per row. All data is saved with zero-offset correction. 

#csv file 
ARRIVALS 
PH01,PH01,PH01,#sitename 
 , , ,#onset 
 , , ,#first motion 
P,S,AML,#phase 
20180407,20180407,20180407,#year month day 
0548,0548,0548,#hour minute 
46.469,51.102,46.469,#second 
0.005,0.005,0.100,#uncertainty in seconds 
 , , ,#peak amplitude 
 , , ,#frequency at P phase 
 
TIME SERIES 
PH01,PH01,PH01,#sitename 
HNE _,HNN _,HNZ _,#component 
_,_,_,#authority 
20180407,20180407,20180407,#year month day 
0548,0548,0548,#hour minute 
42.839,42.839,42.839,#second 
200.00,200.00,200.00,#samples per second 
4258,4258,4258,#number of samples 
0.000,0.000,0.000,#sync 
m/s/s,m/s/s,m/s/s, 
 
--------,--------,--------, 
-0.0006709909,0.0018134047,-0.0010640614, 
-0.0006945866,0.0019957353,-0.0011305584, 
-0.0007632287,0.0021609052,-0.0012978734, 
 
… more data 
 
0.2632255554,0.4593577981,0.0390293375, 
0.2496086955,0.4775865674,0.0227354281, 
0.2339282781,0.4935994744,0.0048155603, 
 , , , 
 
END,END,END, 
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Raw Text format 

When you save your seismogram as a text file, the fields are tab separated and the data is in 

raw integer counts as stored by the recorder (not zero-offset corrected by Waves). The 

conversion factors are listed in the TIME SERIES header section to allow you to turn raw 

counts into ground motion values. Convert using the operation:  

counts ÷ Counts/Volt ÷ Volts/Unit ÷ Flat Gain = units 

e.g. 2835 ÷ 419430.4 ÷ 1.02 ÷ 1.09 = 0.0060794807 m/s2 (620µg) 

 

ARRIVALS 
PH01 PH01 PH01 #sitename 
      #onset 
      #first motion 
P S AML #phase 
20180407 20180407 20180407 #year month day 
0548 0548 0548 #hour minute 
46.469 51.102 46.469 #second 
0.005 0.005 0.100 #uncertainty in seconds 
----- ----- ----- #peak amplitude 
----- ----- ----- #frequency at P phase 
 
TIME SERIES 
PH01 PH01 PH01 #sitename 
HNE _ HNN _ HNZ _ #component 
_ _ _ #authority 
20180407 20180407 20180407 #year month day 
0548 0548 0548 #hour minute 
42.839 42.839 42.839 #second 
200.00 200.00 200.00 #samples per second 
4258 4258 4258 #number of samples 
0.000 0.000 0.000 #sync 
m/s/s m/s/s m/s/s #units 
419430.4 419430.4 419430.4 #Counts/Volt 
1.020 1.020 1.020 #Volts/Unit 
1.090 1.090 1.090 #Flat Gain 
-22.2222 -22.2222 -22.2222 #latitude 
147.4747 147.4747 147.4747 #longitude 
 
 
counts counts counts  
-------- -------- --------  
2835 -4858 942  
2824 -4773 911  
2792 -4696 833  
2742 -4568 764  
 
… more data 
 
134228 193893 33672  
130927 200633 27422  
125860 208443 19633  
119512 216941 12037  
112202 224406 3683  
                               
                         
END END END  
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Save Screenshot 

Although most computers have a screenshot feature, Waves allows you to save 

a PNG format image of just the data window, excluding the control panel and 

window frame. If you have many channels in the scrolling window, the screenshot 

will be very tall. 

 
Computer window screenshot (above) vs. a Waves window screenshot (right) 

Save Fourier 
You can also save the data that is displayed in the Fourier transform window to 

a text file. Right-click on a channel to display the frequency spectrum for the 

entire channel recording, or right-click and drag a portion of the data you wish 

to analyse and its frequency spectrum will appear in the Fourier window. 

By selecting File ▶ Save Fourier the data that is being displayed in the Fourier 

transform window will be output in three columns, the first showing the frequency 

point (in Hz) followed by the real and imaginary values of the spectrum. 

Print 
If you would like to print your waveform you can use the File ▶ Print or ⌘-P 

command. It will print effectively the same information as the Waves screenshot, 

except that it will print up to 9 channels per page to the maximum scale to fill 

the page. 

Close and Quit 

Close the Waves window using File ▶ Close or ⌘-W to return to an empty Waves 

window. Use this command again or File ▶ Quit or ⌘-Q at any time to quit 

Waves. 
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Generate Report 

More and more, Gecko recorders are being used for 

monitoring blasts and vibrations in mines, quarries, and 

from civil construction and demolition works. 

Extraordinary events often require a summary report of 

the data recorded to show whether the ground motion 

and air pressure vibrations were within permitted levels. 

While viewing an event recording in Waves, use 

the File ▶ Generate Report option to open a 

dialogue box that allows you to customise the 

content of the report.  

You can set a logo to appear on the report, and 

it will be saved for future reports. Use a JPG or 

PNG file. It will be rescaled to fit a 120x90 pixel 

area. The title of the report can also be modified 

and will also be retained for future reports. 

Three free text fields are available per 

report. Site and Location are 20-

character fields, and you can enter 

about 300 characters in total that will 

appear over three lines in the Notes 

field. All of these text fields appear in 

the header of the report. 

The check-boxes allow you to select 

which sections to include in the 

report, and the Fourier Spectrum 

section allows you to select an upper 

limit to the frequency plot (X) axis to 

show more detail in the lower 

frequency range. Depending on your 

sample rate, the plot limit options will 

be to 25Hz, 50Hz, 100Hz, 250Hz and 

MAX (half the sample rate). 

A sample of the waveform and 

Fourier Spectra plots from the report 

is shown at left. 

 

 

Waves Blast Report
Time: 2021-05-21 09:48 AM AEST
2021-05-20 2348 05 (UTC+10)
Recorder: GECKO
3D Sensor: Miniseis Geophone #0
1D Sensor: Miniseis Microphone #0

Site Name: Hunter Region
Location Name: 1km NW of main pit
Latitude: -32.82146
Longitude: 151.57190

Notes: No reports from local residents
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11.22 Hz

3D sensor Y
1.445 mm/s
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3D sensor Z
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10.97 Hz

1D sensor
114.988 dB
10.21 Hz
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The second page of the report, if enabled, 

will show a “Zero-Crossing” plot in the 

style of the USBM RI8507 chart. This is a 

simplified method of plotting velocity 

amplitudes by calculating the peak’s 

frequency based on the time between the 

waveform crossing the zero-line. The plot 

frequency range is fixed from 1-100Hz 

and the particle velocity range is from 1-

110mm/s. The standard threshold levels 

for residential structure damage potential 

is overlaid as a guide to the safe blasting 

and vibration levels. 

If the 3D and 1D sensor name and serial 

numbers are available, these will be 

added to the header, along with the 

geographic location of the station – click 

the pin icon to open in Google Maps. 

Get Waveforms 

If data from your seismic monitoring network is being received by the SRC eqServer 

earthquake observatory data management system, you can extract waveform data from that 

archive directly from Waves without having to log in to eqServer using a web browser. 

 

Click on the cog symbol to view the eqServer settings to enter the web address and login 

credentials of your eqServer. Once connected, set the date, time, and length of the data 

extraction request. If you leave the station and radius fields empty, all data on the server for 

that time will be returned, or enter a station code to only return data from stations within the 

nominated radius of that station. Once extracted, the seismograms will appear in your Waves 

window, ready for analysis. 

Waves Blast Report
Time: 2021-05-21 09:48 AM AEST
2021-05-20 2348 06 (UTC+10)
Recorder: GECKO
3D Sensor: Miniseis Geophone #0
1D Sensor: Miniseis Microphone #0

Site Name: Hunter Region
Location Name: 1km NW of main pit
Latitude: -32.82146
Longitude: 151.57190

Notes: No reports from local residents
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Edit Menu 

Settings 

Display 

The first setting in this tab 

relates to the way the time is 

displayed. By default Waves 

displays data in UTC time, 

but if your recorder uses a 

UTC offset to define local 

time for file names, you can 

choose to display data using 

the stored UTC offset 

(Recorder Setting) or you 

can get Waves to always 

display data with a Custom 

UTC Offset (e.g. +10.0 

hours for Australian Eastern 

Standard Time). 

There is a minimum vertical space required by Waves to draw a channel, but you can also set 

it to display a maximum number of channels, for example if you wish to display only 3 or 6 

channels on screen at a time. Enter the maximum number of channels you wish to display in 

the field shown. The remainder of the channels are accessible by scrolling. 

When displaying pressure (usually a recording from a microphone), Waves can display 

amplitude in Pa (pascal) or as SPL (sound pressure level, measured in dB). When plotting 

acceleration, Waves can display amplitude in g (gravity), in m/s2 (metres per second squared, 

shown as mm/s2 or nm/s2 as required) or in gal (cm/s2). 

As discussed in the Toolbar section on Amplitude Grouping, you can fix the amplitude scale 

for native acceleration, velocity and displacement data. These fixed values are defined for 

acceleration, velocity and displacement using the values you enter in the boxes. 

When your final waveform is closed, an empty Waves window remains. This empty workspace 

can be hidden so that only the toolbar remains. 

When you mark a P-wave arrival time and an S-wave arrival time, Waves can display the 

time difference. You can turn the “Show S minus P” feature on and off with the checkbox. 
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Controls 

As discussed in the section on Zooming, 

the speed of zooming can be 

customised. This affects the step size of 

the incremental zoom when using the 

toolbar buttons or keyboard shortcuts, 

and also the speed of zooming when 

using the scroll wheel while holding 

down the right-mouse-button or 

CONTROL key. 

The size of the steps used to horizontally 

scroll the time line (by using the toolbar 

buttons or keypad arrows) can also be 

adjusted. This also affects the speed of timeline scrolling when using the mouse scroll wheel 

while holding down the ALT key. 

Some pointing devices such as multi-touch trackpads can behave erratically when zooming 

or scrolling. A scroll-wheel mouse is recommended for the best user experience. 

Filter & Convert 

You can set the pass band of the 

frequency range of your favourite Preset 

filter here. Once defined, these values 

are displayed in blue in the toolbar. 

The Toolbar filters buttons can apply to 

all channels or just those that are 

currently visible. 

When the 2D or 3D vector sum peak 

particle plots are performed, the 

integrated data (converting from 

acceleration to velocity, or from velocity 

to displacement) can be affected by 

conversion artefacts that usually need to be filtered out. 

This group of settings allows you to choose to automatically apply a preset pass band filter to 

manually integrated data (when you press the channel    buttons, to one all or 

all grouped channels), or integrate the data based on the current frequency range, which may 

or may not be filtered. 
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Magnitude 

The P wave and S wave velocity values are used by a simplified method to estimate an 

earthquake’s distance from a station. You can set a single P and S velocity and typical 

earthquake depth to suit your local region. Changing these will affect the distance and 

magnitudes calculations.  

 

The default formula for local Richter magnitude is: 

log(A*2080)+log(D)+0.00301*D+0.7 where A is 

amplitude of the peak displacement of the vertical 

channel (in millimetres, after being filtered by the 

customisable high pass filter, default is 2.0Hz+) 

and where D is the estimated distance from the 

station to the earthquake based on the P & S picks 

and velocities. You can modify this formula using 

standard mathematical operations and the A & D 

variables. 

These velocities and magnitude formula are not used by the Location feature introduced in 

Waves 4.0. It only applies to the time series waveform view for rapid magnitude estimation. 

Destinations (formerly “Folders”) 

You can set Waves to always use a particular folder when opening, saving or quick-saving 

files. Leaving the boxes unchecked will usually set the destination as the last folder used. 

 

Here you can also define the login details of an eqServer from which you can extract waveform 

data or to which you can save earthquake location solutions. This tab also allows you to define 

which FDSN server to search for station response data (Waves was previously hardwired to 

searching the IRIS server).  
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STA/LTA 

You can modify the STA/LTA settings to help 

tune a Gecko recorder’s trigger routine. After 

changing one of the settings, click the Apply 

button to see the effect on the yellow 

STA/LTA ratio plot on the waveforms if you 

have this display enabled. 

The yellow trace overlaid on your ground 

motion recording is the simulated STA/LTA 

ratio, which shows you how a Gecko 

recorder’s STA/LTA trigger algorithm would 

see this data with and without recorder’s 

STA/LTA filter active. eqServer uses a 

different STA/LTA algorithm to analyse 

incoming streaming data, so this STA/LTA 

ratio can also be simulated in Waves. The simulated STA/LTA ratio can be toggled on and off 

by pressing the “A” keyboard shortcut. 

STA stands for Short Term Average and LTA for Long Term Average. The STA/LTA Ratio is 

the average signal level over a short time period (e.g. 2 seconds) compared to the average 

signal level over a longer time period (e.g. 20 seconds). The ratio of the STA level to LTA 

level is plotted in yellow on the screen. The scale of this plot is related to the STA/LTA ratio 

trigger Threshold, which is a level at which you would expect the seismic recorder to declare 

that an event is happening. The trigger threshold is plotted at the zero-level of the channel, 

so the Y-axis range is a ratio of zero to twice the threshold level. 

In the example below, the STA setting is 1 second, the LTA is 20 seconds, and the threshold 

is 3.0. Before the earthquake the STA and LTA values are similar and the ratio of the short 

term average signal divided by the long term average signal is around 1, but as soon as the 

earthquake/blast hits, the average signal level in the STA period is many times larger than 

the average signal in the LTA’s previous 20 seconds, so the ratio shoots through the threshold. 

At this point the recorder would declare a “trigger” and perform any related actions. 
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Arrivals 

The list of arrival phases in the drop-down list in the toolbar is populated by a default list of 

commonly used phases. These are simply text fields that are assigned to the Set marker. 

You can add or remove phases from the toolbar’s drop-down list by editing this text field. 

 

Remove Startup Image… 
Waves is a free software application that is supported by a 10-second advertisement when 

the program starts. If you have purchased a product key to remove the pop-up ad, you can 

enter the code by selecting this menu item or by clicking on the advertisement. Your computer 

must have Internet access to confirm the validity of your key with our register. Please note 

that a key can only be used once and is locked to the computer user profile that activates it. 

Note that this will not remove the small advertisement that is in the toolbar of the Location 

feature that was launched in Waves 4.0. 

Clip Visible to New File 
You may wish to create a new seismogram file with a subset of the data in the currently-

displayed Waves data file. You can remove channels or restrict the time period so that you 

are only left with data relevant to your analysis requirements. The Edit ▶ Clip Visible to 

New File menu item (also accessible using the ⌘-L keyboard shortcut) will open a new 

window that contains only the data visible in the vertically scrolling main window in Waves. 

This means that any channels that have been hidden will not be exported to the new window, 

and only the data from the current timeline zoom level will be exported to the new window. 

Filter settings will be carried across to the new window, although they can be cleared so that 

the original raw data can be displayed. 
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Stack to New File 

Seismic recording equipment can be used in exploration applications as well as earthquake 

seismology. It is not uncommon to record dozens of vertical geophones over a small area to 

improve the signal-to-noise ratio to better see events. 

The method of “stacking” waveforms helps to reduce the random noise as it does not correlate 

from sensor to sensor, whereas the event signals do correlate. 

By marking a common arrival phase on each channel using the X keyboard shortcut then 

initiating the “Stack” menu command, a new window will appear with the waveforms stacked 

onto the earliest X marker. 

Set Arrival Error 

After picking P or S arrival, you can right-click and drag to highlight a time span around the 

marker to indicate your range of uncertainty around your time pick. 

 

By then using the “E” keyboard shortcut or selecting the “Set arrival error” item from the Edit 

menu, the arrival will then be assigned an uncertainty of the greatest deviation from the pick 

time in your highlighted section. If your earthquake location supports it, this uncertainty value 

can be assigned to the phase time and weighted accordingly in the location algorithm. 

If you mark a P or S arrival time, the default uncertainty will be the time equivalent of two 

data samples (i.e. ±0.02 seconds for data recorded at 100 samples per second). 

If you mark the arrival as an impulsive i+P, i-P or iS, the default uncertainty will be one data 

sample (i.e. ±0.01 seconds for data recorded at 100 samples per second). 

If you mark the arrival as an emergent eP or eS, the default uncertainty will be ten data 

samples (i.e. ±0.1 seconds for data recorded at 100 samples per second). 

Remove Spikes 

In digital data it is possible that one or more sequential samples can become corrupted, 

presenting a “spike” in the data. This feature attempts to correct the data corruption.  
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Display Menu 
The Display menu is used to modify the way the waveform data or on-screen elements are 

displayed. Waves and Java version information is available under Display ▶ About… 

Zero Correction & Amplitude Grouping 

See the section on Toolbar Controls that explains these display modes. 

Channel Sorting 

By default Waves will sort the displayed channels by Station Code in alphabetical order. 

  

You can re-order the stations using the Display ▶ Channel Sorting menu. If you select to 

sort by P arrival it will use the picked P times to sort the stations in order of distance from 

the earthquake. If GPS location is embedded in the data, you can sort stations by their 

Distance from Closest Station (the station that has the earliest P time). If you change your 

P times you can re-apply the menu item to re-sort the channels. If you have started an 

earthquake location solution (see “Location” section later in this manual), stations with no 

manually picked P-wave arrival time will be sorted using the expected P-wave arrival time for 

that station based on the current location solution. 

Horizontal and Triaxial Peak Particle Motion Plots 

See the section on Toolbar Controls that explains the function of these calculated plots. 

Activated by these menu items or the 2D and 3D SUM toolbar buttons, the resulting plot 

appears in a new window. The triaxial plot can be done using the ⌘-G keyboard shortcut. 

Hide and Show Spectrograms and FFT/PSD 

There are also keyboard shortcuts for showing and hiding the frequency plots. Use K to open 

spectrograms on all channels (this can take some time), or L to close them. Use the F shortcut 

to open and close the FFT/PSD window which shows the plot of the current channel.  
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Arrivals Menu 
Whenever you pick a phase arrival time, the data is placed in the Arrivals menu. Each phase 

is time stamped and related to a single station code. You can sort this list by clicking on the 

Time, Station, or Phase headings. 

 

If you wish to remove an Arrival from the list, click the red X next to the Arrival and its marker 

will disappear from the main window. Be aware that this action cannot be undone. 

Use ⌘-C (or select the top item in the Arrivals menu) to copy the list of arrivals to the 

clipboard, which can be pasted into eqFocus for accurate earthquake location and magnitude 

determination, or the arrivals can be pasted into a text file. 

Use ⌘-D (or the second item in the Arrivals menu) to clear all arrivals from the window. 

If you are also running eqFocus, the ⌘-F command will send the arrivals into its Arrivals list. 

The AML value for a station is the peak displacement of ground motion on the vertical channel, 

in millimetres, for signals above 2Hz. This is used to calculate MLv magnitude in eqFocus. 

A legacy Arrival Code that was used for magnitude determination before displacement 

conversion allowed MLv was the “MAX” arrival, set by swiping the peak velocity of the 

waveform and hitting the M shortcut key (in the Edit menu). This would store the peak raw 

amplitude value and the peak frequency in the selection as a method of calculating 

displacement in eqFocus using response files. 
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Channels Menu 
When a channel is selected, its Y-axis bar is slightly thicker than the others to show that it is 

selected. You can select the first entry in the Channels menu to see the channel information, 

which can also be displayed using the ⌘-I keyboard shortcut or the  button on the channel. 

When you are displaying a merged file, each station code in the merged file is listed in the 

lower section of the Channels menu. By selecting a station code from this menu, you can view 

just this station in the main Waves window. 

If you wish to return to viewing all sites, use 

the Channels ▶ All menu command. 

If you wish to view only the vertical velocity 

channels (or acceleration channels if velocity 

is unavailable) to quickly pick arrivals from all 

of your stations, use the Channels ▶ Vertical 

menu command. 

 

Gecko Histogram Display 
The Gecko seismograph produced by the Seismology Research Centre generates a daily CSV 

file that is updated with a summary line once per minute. Each line records the peak value 

from the triaxial sensor (vector sum) that occurred in the previous minute, the peak from the 

uniaxial channel (if enabled), the current input Voltage, Temperature, GPS position and clock 

information, and the percentage of storage available. 

You can open these CSV files with Waves to plot the Vector Peak channel(s), the Voltage and 

the Temperature to visualise the values over time. To merge more than one CSV file so that 

you can plot many days of data on screen, hold the Control key (on Windows and macOS, or 

hold Shift on Linux) 

while dragging CSV 

files onto Waves. The 

amplitude range of 

each plot scales 

dynamically – zero to 

peak for channel 

data, minimum to 

maximum for volts 

and temperature.  
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Basic Data Analysis 

The P wave 
The first earthquake energy wave to arrive at a seismograph is the P (or Primary) wave. As 

such they are generally easy to pick as there is usually a clear difference between the 

background noise and the earthquake arrival. The P wave is usually most obvious on the 

vertical channel of a 

sensor as the P-wave 

energy is pulsating in 

the direction of travel 

(up to the surface). As 

you can see from the 

top image (left), the 

first vertical marker 

appears to be before 

the first arrival, but by 

zooming in we can see 

start of the P much 

more clearly. 

 

The S wave 
The next major earthquake energy wave to arrive at a seismograph is the S (Secondary or 

Shear) wave. These waves are oscillating perpendicular to the direction of travel, i.e. shaking 

horizontally when it reaches the surface. The S waves (and later surface waves) often do the 

most damage during an earthquake due to this horizontal shaking and the larger amplitude. 

The S wave also usually has a lower frequency than the P wave. 

Due to its motion, S waves are 

usually more obvious on horizontal 

channels, but as the S wave arrives 

in the coda of the P wave it is often 

difficult to determine a clear arrival 

time. Look for a point that correlates 

across the horizontal channels that 

features a drop in frequency and 

increase in amplitude. 
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Rough Magnitude Estimation 

Before Waves included a dedicated earthquake location feature, we could estimate the 

magnitude of an event by using the real ground motion units once a P and S wave arrival had 

been picked. Waves will estimate the distance to the earthquake based on the P velocity and 

S velocity values defined in the “Magnitude” Settings, then apply the formula to estimate 

magnitude based on the estimated peak displacement. 

The default formula used to estimate MLv is applicable for California (USA), South Eastern 

Australia, and other regions of the world with similar ground motion attenuation. Richter’s 

formula is limited in that it only really works for events of up to magnitude 6, and for 

earthquakes within 600km of the station.  

This formula is discussed further in the Settings section of the manual, and it can be 

customised by manipulating the distance and amplitude derived from the waveform. 

The distance and magnitude estimate for each station is written on the vertical channel just 

below the frequency filter and spectrogram buttons. 

 

When you have multiple stations in the same Waves window, Waves will take the average of 

these magnitudes (ignoring outliers, coloured grey) and display the estimated MLv magnitude 

for the event in the top right corner of the toolbar. 

To more accurately determine magnitude using multiple stations, use the Location feature 

introduced in Waves 4.0. 
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Exporting to Google Earth 

Before Waves included a dedicated earthquake location feature, we could estimate the 

location of an event by using station location and distance based on P and S phase times as 

discussed in the previous section. 

If you have picked a P and S wave arrival time on at least three stations, go to the File menu 

and select Save As and select the KML file format to save a Google Earth compatible file. 

 

This KML file contains the station locations and epicentral distance circles for any station that 

has a P and S phase picked. The circles from the three closest stations are filled with a 

transparent orange, and where the three circles overlap a darker orange region indicates an 

area that is likely to contain the earthquake epicentre. 

 

For more accurate earthquake location and magnitude calculation, use the Location feature 

that was introduced in Waves 4.0. 



 

 40 

Accurate Earthquake Location & Magnitude 

Waves 4.0 introduced the ability to use 1D velocity model and wave inversion to accurately 

determine the location and magnitude of an earthquake. It brings the algorithms from our 

past EQLOCL and eqFocus applications to the user-friendly graphical user interface that Waves 

is known for. 

If you have a multi-station recording and have picked at least three arrival times, 

the new location feature button will switch from the Waveform Analysis view to 

the Earthquake Location view. 
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Location Screen 

The Location screen plots one channel of 

waveform data from each station (preferentially 

the vertical channel) spaced vertically by 

distance from the estimated earthquake location. 

The expected P, PG, S and SG arrival time curves 

- based on the 1D model being used - are plotted 

on the timeline in purple. 

Any P, PG, P and SG phases that have been 

picked on the Waveform screen will appear on 

the waveforms in coloured boxes. The colour of 

the box – a gradient from green to red - reflects 

how well the picked phase fits with the current 

solution based on the earth model being used. 

If you wish to defer a phase from the solution, 

click on the coloured box and it will go dark, with 

the phase name changing to the colour 

representing how it fits the solution even though 

it is deferred. Every time you enable or disable a 

phase, the earthquake solution will be recalculated. 

Zooming and Scaling 

Use the scroll wheel on your mouse to zoom in and out to your cursor position while over the 

waveforms. You can also click and drag a box over the waveform area, then click inside that 

box to zoom to the selection. To reset the zoom to the default view, double-click your right 

mouse button, use the blue  button in the top left corner, or press the HOME on your 

keyboard. 

To increase or decrease the amplitude of the waveform signals, use the up and down arrow 

keys on your keyboard. 

You can zoom the map using the mouse scroll wheel, or by double-clicking a point on the 

map, or by using the + and – buttons in the top left corner of the map. Reset the map zoom 

using the blue  button in the top left, or right-click on the map and select “Reload page”.  

You can click and drag to pan around the map, and change from terrain map view to aerial 

image by clicking on the view mode button in the top right corner of the map. 

You can change the split between waveform and map window size by dragging the vertical 

divider bar between the windows left and right. 
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Editing Phase Arrivals 

If you wish to edit the arrival phase picks for a station, click on the grey station code box to 

the left of the distance axis and you will be taken to the Waveform view for that station. 

Because you have started locating the earthquake, Waves can now show you the phase arrival 

times the model expects for the station based on the current solution. These expected phases 

are plotted in grey on the waveform as a guide. This feature can help you see phase arrivals 

the may be obscured in codas or by background noise. 

 

Once you have finished editing your picks, click the Locate button to return to see what effect 

this has had on your solution. 

Earthquake Depth 

The earth model file has a default depth setting of 10km, which you can modify to represent 

the typical depth of earthquake in your region, or set it to 0km when locating surface blasts. 

The initial earthquake location solution is locked at this depth, but you may have sufficiently 

close stations or phases to justify releasing the depth to see if there is a better fit with the 

model. Click the lock button next to the Depth in the toolbar to unlock and lock the event 

depth. If the depth jumps to a negative value, it will be displayed in red text. 

Use the depth slider to see how the arrivals fit at various depths. The depth will be locked to 

the value set by the slider 

Location Quality 

The quality of the solution is the standard deviation from the model of the included phases, 

in seconds, rated from Good (<1.0) to Fair (1.0>2.0) to Poor (>2.0). 
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Location Settings 

Model 
The default 1D layered models included in Waves are based on the IASPEI global model, and 

a Custom model that the Seismology Research Centre uses for southeast Australia. You can 

edit these models or create new models to suit your region of the world. Click on the settings 

cog in the toolbar to edit, add or delete models. 

 

To add a new model, click on the drop-down menu and select the “New Model” line at the 

top, then enter a unique name. The values from the previously selected model will copy into 

this new model. You can enter up to 5 layers of velocity, defining the P and S velocity of each 

layer to the nominated depth (from the previous layer). Modify these as required, then set 

the preferred default depth of earthquake for the model. 

The final setting that you can modify is the magnitude calculation formula. This formula 

follows the same rules as the Magnitude settings on the waveform analysis side of Waves, 

where A is amplitude of the peak displacement of the vertical channel in millimetres, and D 

is the distance from the station to the earthquake in kilometres. 

Click Save Changes when you’re happy with the settings, then click OK to exit back to the 

Location view to see how the new model fits with your phase picks. 

Map Zoom 
With “Smart Zoom” enabled, as you refine your location the map will refresh to a zoom level 

that shows the earthquake location and your network of stations. If you would prefer that the 

map stays at a specific zoom level, uncheck the Smart Zoom tick box and set the zoom level 

with the slider. As a guide, the zoom level is displayed under the ± zoom buttons on the map. 

If you are zoomed to the appropriate level you will be able to see the epicentre move as your 

location iterates with each change of depth or inclusion/deferral of phase arrival. 
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Saving the Event Location 

Waves 4.2 introduced additional file save features, along with eqServer database integration. 

 

You can save your solution to an “EQLOCL” text file that contains the location and magnitude, 

along with a number of fields that provide more information about the earthquake. Manually 

enter a place name from the map, enter any comments in the free text field, and optionally 

select values from the other drop-down menus to help define the quality of your location. The 

“Accuracy” of the location is automatically pre-selected. 

The saved file does not contain the waveforms, only a text-based event summary. If you go 

back to the waveform analysis side of Waves and save your waveform file in PC-SUDS format, 

the file will flag if the phases were included or deferred in your solution so that you can 

replicate the result from the waveform file. It will not include the model, so if you are sharing 

your waveforms, be sure to share your model information as well. 
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Sharing Model Files 
The models created by Waves are text files stored in the following location on your computer: 

/Users/username/eqsuitefiles/waves/models/ 

To share a model file with a colleague, simply send them the model file you created and get 

them to copy it into the equivalent folder on their computer. 

Station Response Files 
If you open a waveform file and Waves cannot find its response file at the selected FDSN 

server, if you have a copy of the relevant station.xml file you can drag it onto the Waves 

window, or you can copy it to the following folder on your computer: 

/Users/username/eqsuitefiles/waves/response/ 

EQLOCL Accuracy Codes 
The very first software application developed by the SRC in the late 1970s was EQLocL – a 

program to calculate EarthQuake Location for Local events. The algorithms are still at the 

core of Waves’ location feature. 

At the time we also defined a system for rating the accuracy of a solution, summarised below. 

This is how Waves auto-selects the Accuracy of your solution. We still use this today, but you 

can use the Accuracy code for your own definition or for another purpose entirely. 

Conditions A B C D E F U 

Local seismological model used • 
      

Uncertainty in latitude, longitude, and 
depth (km) and azimuth (degrees) 

<50km, <330° 
    

• 
  

<10km, <270° 
   

• 
   

<5km, <180° 
  

• 
    

<2km, <50° • • 
     

An earthquake did occur, and was probably in this general area 
     

• 
 

Micro earthquake very close to seismograph       • 

 

Saving to eqServer 
If you have an eqServer data management 

system, it will be creating solutions for auto-

detected events. You can save your solution to 

the eqServer database, optionally associating 

it with an existing event and setting it as the 

preferred solution for the event. eqServer will 

also use its place name database to name the 

event if you’ve left it blank. 

 



 

 

GECKO COMPACT

GECKO SEISMOGRAPHS & ACCELEROGRAPHS

src.com.au

3+1 Channel
Digitisers
To Record
Any Brand
Of Sensor

Low Cost Portable
Velocity and
Acceleration

Vibration
Monitors

Professional
Earthquake

Seismographs
and

Accelerographs

BLAST, FORCE and SMA

SMA-HR and -XR, TREMOR,
PRISM-SP, -MP and -LP


